Monday, April 05, 2010

Event log errors 6398, 7076, 6482 on Sharepoint Server

Original blog entry: http://www.stationcomputing.com/scblogspace/Lists/Posts/Post.aspx?List=ec6ce151-566a-499e-94a5-e153fafda404&ID=4

We have been researching the issues outlined in the above blog on our Sharepoint development server. We also requested the hotfix from MSFT. If the hotfix does not alleviate the issues, we will apply the steps outlined in the blog and let everyone know how it goes.

Error 6398 The Execute method of job definition Microsoft.Office.Server.Administration.ApplicationServerAdministrationServiceJob (ID 979c174b-76e3-4376-877c-c6740b35a7d4) threw an exception. More information is included below. Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Error 7076 An exception occurred while executing the Application Server Administration job. Message: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Error 6482 Application Server Administration job failed for service instance Microsoft.Office.Excel.Server.ExcelServerSharedWebServiceInstance (a716c72c-13c3-4a94-a05e-9d166fb02402). Reason: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

Ok, so the search services are playing up again, and this time I reckoned it had to be the Office Search Server Search. So this is what I did to fix the problem:

1: Recycle Office Server Search (Operations / Services on Server / Stop), stsadm command line start on the lines of:

STSADM -o osearch -action start -role Index -farmcontactemail email@yourcompany.com -farmperformancelevel PartlyReduced -farmserviceaccount searchserviceaccount -farmservicepassword searchserviceaccountpassword -defaultindexlocation "locationoftheindexfiles"

Where:

email@yourcompany.com: This is the email address related to the farm administrator

searchserviceaccount: This is the account applied to Office Search Server Search

searchserviceaccountpassword: This is the password related to the Office Search Server Search account above

Locationoftheindexfiles: F:\Program Files\Microsoft Office Servers\12.0\Data\Office Server\Applications

2: Ensure the Tasks folder permissions (c:\windows\tasks) are set against the WSS_WPG (the search service account is a member of this group)

3: Reset the indexer to the index server (Central Admin, Shared Services Provider, Edit, Indexer)

4: Reset the crawl (Central Admin, Shared Services Provider, Search Settings, Reset all Crawled Content) – note you may have to wait whilst the indexer move is in progress though you will be informed.

5: Run a full crawl to update the index

Carried out the above, checked the event logs for the same errors after 10 minutes and no repeat of them.

Interesting though how these type of errors occur, since there doesn't appear to be any trigger for them. All other services appear to be ok. The only thing I can think of that may cause this is an error in the index itself, stopping certain data going to the index.